Identity manager postgres patching fails with LCMVIDM71147
search cancel

Identity manager postgres patching fails with LCMVIDM71147

book

Article ID: 419485

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

When applying the postgres patch in Step 2 substep 10 in https://knowledge.broadcom.com/external/article/412021 the request fails with:

LCMVIDM71147
Failed to update Auth provider with VMware Aria Suite Lifecycle hostname

Additionally, the vIDM /opt/vmware/horizon/workspace/logs/horizon.log on the appliance nodes contains the following error:

too many open files

Environment

VMware Identity Manager 3.3.7

Cause

The horizon-workspace service on the vIDM nodes has exhausted the available file descriptors, entering a "too many open files" state. This prevents the service from responding to the API calls required by Aria Suite Lifecycle to complete the "update auth provider" task.

Resolution

To resolve this issue, restart the affected service on the vIDM nodes to release the file handles.

  1. Log in to each vIDM node via SSH.
  2. Restart the horizon-workspace service on all three nodes by running the following command:
    1. service horizon-workspace restart
  3. Log in to the VMware Aria Suite Lifecycle interface.
  4. Retry the failed request 

Additional Information

If the request fails again with the same LCMVIDM71147 error but there are no "too many files open" messages in /opt/vmware/horizon/workspace/logs/horizon.log then you may need to re-register LCM to IDM using the following KB

https://knowledge.broadcom.com/external/article/415172/logging-in-to-lcm-as-an-identity-manager.html