"Service Accounts" option is missing for tenant users.
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"Service Accounts" option is missing for tenant users.

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Article ID: 419398

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Setting up service accounts option for the tenant users is not working as expected.
  • Tenant users cannot see the 'Service Accounts' option even after adding the following rights to their roles.
    View Service Accounts
    Manage Service Accounts

Environment

VMware Cloud Director 10.6.x

Cause

Tenant users can use only those rights from their roles that are published to their organizations. This issue can happen if the rights are only added to the roles but not published to the tenant itself.

Resolution

To resolve the issue, ensure the rights are enabled for both the tenant organizations and the user roles.

  1. To verify the rights available for the tenant organization, refer to the section View and Edit a Rights Bundle Using VMware Cloud Director in Managing Rights Bundles in VMware Cloud Director
    Enable and publish the right 'Manage Service Accounts' to activate the 'Service Accounts' option. This will automatically enable the view rights as well.

  2. To verify the rights available for the tenant user roles,
    1. For global tenant role : Refer section View and Edit a Global Tenant Role Using Your VMware Cloud Director in Managing Global VMware Cloud Director Tenant Roles
    2. For custom tenant role, refer Edit a Custom Tenant Role

Enable and publish the right 'Manage Service Accounts' to activate the 'Service Accounts' option. This will automatically enable the view rights as well.

Log into the tenant portal as a tenant user and the Service Accounts option should be available.

 

Additional Information

Managing VMware Cloud Director Rights and Roles

Create a Service Account Using Your VMware Cloud Director Service Provider Admin PortalVMware Cloud Director Tenant Portal