ESXi host loses connectivity after enabling Trunk mode on physical switch ports
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ESXi host loses connectivity after enabling Trunk mode on physical switch ports

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Article ID: 419367

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • You are transitioning from access mode to trunk mode on physical switch interfaces in turn connecting to the ESXi management kernel.
  • While performing the above activity, it is observed that the ESXi loses network connectivity.
  • When the switch ports are changed from access mode to trunk mode, it results in connectivity disruption.

Environment

VMware vSphere ESXi

Cause

Directly converting active management uplinks from access to trunk mode causes expected loss of connectivity due to changes in VLAN handling. A staged transition is required to maintain connectivity.

 

Resolution

This is an expected behavior due to changes in VLAN handling after switching the switch port configuration from access to trunk and not having vlan tagged on ESXi management kernel port-group

Please find below steps for a staged transition:

  • Create a temporary port group using a single uplink that remains in access mode.
  • Move vmk0 to this temporary port group to maintain management connectivity.
  • Configured the second uplink to trunk mode on the physical switch side and allow the required vLAN/s.
  • Configure the new management port group with the required VLAN tagging and assign the second uplink (Trunk) as active.
  • Migrate vmk0 to the new management port group.
  • Reconfigure the remaining uplink into trunk mode on the physical switch.
  • Migrate the newly configured uplink to the new management port-group.

Note: If you do not have redundant uplinks or are facing any other circumstances preventing management kernel migration, please open a case with Broadcom support team for further assistance/troubleshooting