Error while reconfiguring Vmware Live Site Recovery : "http://1##.0.0.#:9286/sdk invocation failed with "java.net.SocketTimeoutException: 30,000 milliseconds timeout"
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Error while reconfiguring Vmware Live Site Recovery : "http://1##.0.0.#:9286/sdk invocation failed with "java.net.SocketTimeoutException: 30,000 milliseconds timeout"

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Article ID: 419353

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms :

  • Registering Vmware Live Site Recovery fails with following error:

    http://#.#.#.#:9286/sdk invocation failed with "java.net.SocketTimeoutException: 30,000 milliseconds timeout

  • Following Socket timeout error observed in VLSR server : 

    (in /var/log/vmware/drconfigui/dr-config.log)

    YYYY-MM-DDTHH:MM:SS.## [srm-reactive-thread-153] WARN com. vmware.dr.configservice. summary. GetConnectedToCloudData ########-####-####-####-############# getConnectedToCloudData - Failed to get active agent:

    com.vmware.vim.vmomi.client.exception.ConnectionException: http://#.#.#.#:9286/sdk invocation failed with "java.net.SocketTimeoutException: 30,000 milliseconds timeout on connection http-outgoing-39 [ACTIVE]"

at com.vmware.vim.vmomi.client.common.impl.ResponseImpl.setError (ResponseImpl.java:265)
at com.vmware.vim.vmomi.client.http.impl.HttpExchangeBase.setResponseError (HttpExchangeBase.java:362)
at com.vmware.vim.vmomi.client.http.impl.HttpExchangeBase.setResponseError (HttpExchangeBase.java:362)
at com.vmware.vim.vmomi.core.tracing.NoopTracer$NoopSpan.runWithinSpanContext(NoopTracer. java:120)
at com.vmware.vim.vmomi.client.http.impl.TracingScopedRunnable.run(TracingScopedRunnable. java:17)
at com.vmware.dr.ui.tools.utilities.ThreadContext.lambda$wrap$1 (ThreadContext.java:55)

Environment

VMware Live Site Recovery 9.0

Cause

Name resolution for vCenter during registration of VLSR taking longer time (more than 10-15 seconds) resulting in the socket timeout error.

(in /var/log/vmware/dr/drconfig.log)

YYYY-MM-DDTHH:MM:SS.## warning drconfig[01239] [SRM@6876 sub=IO.Connection opID=########-####-####-####-#############-validateConnection: call] Address resolution took too long; <resolver p:0x09007fa50007c150, 'vcenter.example.com:443', next: (null)>, async: true, duration: 10011msec

YYYY-MM-DDTHH:MM:SS.## verbose drconfig[01239] [SRM@6876 sub=IO.Connection opID=########-####-####-####-#############-validateConnection:call] Attempting connection; <resolver 0x00007fa50007ch. D> 'vcenter.example.com:443"  next :< TCP ' #.#.#.# : 443'>>, last e: 0 (success)

Resolution

  • Involve Administrators managing DNS / Domain Controller to investigate delay in resolving forward/reverse addresses (of vCenter and VLSR).

  • Once fixed, re-register VLSR from Appliance Management UI.