Gateway MPP update fails, /var/log volume 100% usage.
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Gateway MPP update fails, /var/log volume 100% usage.

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Article ID: 419348

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Updated On:

Products

CA API Gateway

Issue/Introduction

Customer could not install gateway MPP, because the /var/log volume has run out of space.

Environment

All Supported versions of API Portal

Cause

  • Found multiple sendmail and postfix processes.
  • Observed that thousands of files were created under /var/spool/postfix/maildrop, causing the /var volume to fill up.

  • Under /var/log volume, the following files are constantly growing in size.

    mail.log

    mail.info

    daemon.log

    syslog

    ----------

    Following message is logged in these files..

    "warning - mail_queue_enter: create file maildrop/xx.xx: No space left on device"

Resolution

  • Identified scripts in crontab that runs every second.

  • These scripts were not redirecting their output, resulting in emails being sent to the local root user, thereby flooding the mail queue.

  • Add this to redirect to all the jobs: > /dev/null 2>&1

  • Cleanup files in /var/spool/postfix/maildrop manually (rm *).

This stopped the constant update to /var/log system log files.

Now, one can successfully run MPP update.

Additional Information

https://serverfault.com/questions/680782/why-are-there-so-many-files-in-var-spool-postfix-maildrop