HCX - Windows OS with Sentinel agent show/appears as "Disconnected".
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HCX - Windows OS with Sentinel agent show/appears as "Disconnected".

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Article ID: 419306

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Updated On:

Products

VMware HCX

Issue/Introduction

HCX is failing to establish a connection with Windows VMs that have the Sentinel agent installed.

Environment

VMware HCX OSAM (OS Assisted Migration)

Cause

The "disconnected" status can be attributed to several factors, including VM Network Connectivity Issues, Firewall restrictions, Disk Encryption or Antivirus Interference, or a Sentinel Agent issue, as detailed below.

Sentinel agent is repeatedly attempting to reinstall because it's not running as expected (as shown in the C:\ProgramData\VMware\HCX\OSAM\sentinel.log below)

  • sentinelService-####-##-##T##-##-##.315.log:
    • YYYY-MM-DD HH:MM:SS.ms+1100      ERROR   getSoftwareKeyValueString: Failed to get string value for value name: [SentinelServiceRunMode] under key: [VMware, Inc.\HCX\OSAssistedMigrationService]. Error: The system cannot find the file specified.
      YYYY-MM-DD HH:MM:SS.ms+1100      WARN    Failed to get run-mode for sentinel service. Error: The system cannot find the file specified.. Defaulting to sentinel service mode
      .
      .
      .
      YYYY-MM-DD HH:MM:SS.ms+1100      ERROR   getSoftwareKeyValueString: Failed to get string value for value name: [SentinelServiceRunMode] under key: [VMware, Inc.\HCX\OSAssistedMigrationService]. Error: The system cannot find the file specified..
      YYYY-MM-DD HH:MM:SS.ms+1100      WARN    Failed to get run-mode for sentinel service. Error: The system cannot find the file specified.. Defaulting to sentinel service mode

Resolution

Please perform the below steps,

  • Reboot the machine
  • Reinstall the Sentinel agent with admin privileges.

Should the failure remain unresolved, engage Microsoft for further support.

Additional Information

When installing the Sentinel Agent on a Windows operating system, you may encounter this issue. For detailed information and resolution steps, please refer to KB article 400723