CSV files exported from vSphere Client display garbled characters
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CSV files exported from vSphere Client display garbled characters

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Article ID: 419298

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Updated On:

Products

VMware vCenter Server 8.0

Issue/Introduction

If you open the CSV files exported from the vSphere Client by using export button at the bottom left corner of the list view on Microsoft Excel or other application, you see characters in the file such as Japanese and Chinese are not properly displayed.

Environment

vCenter Server 7.x

vCenter Server 8.x

Cause

The CSV file is exported in UTF-8 format but is missing a byte-order mark (BOM).

Resolution

This issue is fixed in vCenter Server 7.0 U3v and 8.0 U3b.

 

Workaround:

  • Collect the information using PowerCLI.

    Example of exporting all virtual machines in vCenter Server:
    Get-VM | Select Name, NumCpu, MemoryGB, VMHost, PowerState, ProvisionedSpaceGB, UsedSpaceGB | Export-Csv -Path C:\export\VM_Inventory.csv -Encoding utf8


  • Use third party application to convert the CSV file in UTF-8 with BOM format.