"It appears you have not been granted access to manage your token" when attempting to access dedicated vCenter in VMware Cloud Director
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"It appears you have not been granted access to manage your token" when attempting to access dedicated vCenter in VMware Cloud Director

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Article ID: 419264

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

When attempting to access a dedicated vCenter in VMware Cloud Director, the following error message is received:

It appears you have not been granted access to manage your token. Please contact the administrator to grant you access.

Environment

VMware Cloud Director 10.6.x

Cause

Rights are missing for the tenant user to access the vCenter.

Resolution

Add the following rights to the rights bundle used by the tenant:

  • View SDDC
  • Manage SDDC
  • Manage SDDC Proxy
  • Manage user's own Token
  • Manage all users' Tokens

After adding the rights, "publish the rights bundle" and then "add the rights to the user's role".

For further assistance on rights management, see Managing Rights Bundles in VMware Cloud Director.

If the issue persists after adding and publishing the rights, the proxy may need to be re-configured. Refer to Customer end tenant is clicking "OPEN VSPHERE" button for SDDC but it never loads and shows blank screen for the required steps.