Excessive Task Versions Created by "Distribute Software Updates" Task
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Excessive Task Versions Created by "Distribute Software Updates" Task

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Article ID: 419228

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Updated On:

Products

IT Management Suite Patch Management Solution

Issue/Introduction

The default "Distribute Software Updates" task (Manage > Jobs and Tasks > System Jobs and Tasks > Software > Patch Management > Distribute Software Updates) in the Patch Management Solution creates a new task version in the database after each Patch Distribution action. Over time, this results in an excessive number of task versions, which significantly increases the size of the task's XML in the database, potentially leading to performance issues.

 

In one observed instance (as seen on screenshot above), a task with 158 versions had an XML size of 114KB , while another server accumulated 14,357 modifications and an XML size of 10 Mbytes.

Environment

ITMS 8.7.x, 8.8
Patch Management 8.7.x, 8.8

Cause

The "Distribute Software Updates" task was configured to re-save itself on each execution (after each Patch Distribution action), which generated an unnecessary new version in the database.

Resolution

The root cause of the task creating extra modifications (new versions) was fixed in our next ITMS 8.8.1 release.
The fix removes the re-saving of the task on each execution. After upgrading to this version (or newer), there will be no new version saves for the "Distribute Software Updates" task when patch updates are distributed.

 

In the meantime, here are the steps on how to clean up "Distribute Software Updates" task versions:

 

Cleanup of Existing Old Task Versions (Manual/Scheduled)



Automatic Deletion of Task Instances

Once the fix is applied, you can clean up the existing old versions of the "Distribute Software Updates" task using the following methods:

1. Using the "Clean up Task Data" Task

You can use the built-in clean-up task to purge unnecessary old task data.

  • Set the minimum/maximum amount in the "Clean up Task Data" task (Settings > All Settings > Maintenance > Server Tasks > Task Service > Clean up Task Data) to keep tasks instances, purge unnecessary old task instances, and purge old tasks instances.

     

    • Reference: For more information, refer to the official documentation on cleaning up task data.

    • Once configured, start the "Clean up Task Data" task to purge old, unnecessary task data.

 

2. Using the "Clean up Task Version Data" Task

You can use the built-in clean-up task to purge unnecessary old task versions.

  • Set the maximum amount in the "Clean up Task Version Data" task (Settings > All Settings > Maintenance > Server Tasks > Task Service > Clean up Task Version Data).

     

    • Reference: For more information, refer to the official documentation on cleaning up task version data.

    • Once configured, start the "Clean up Task version Data" task to purge old, unnecessary task versions.

       

 
OR you can do a:

Manual Deletion of Task Instances

You can manually delete old task instances, which will then allow the cleanup task to purge old versions.

  1. Open the "Distribute Software Updates" task (Manage > Jobs and Tasks > System Jobs and Tasks > Software > Patch Management > Distribute Software Updates) in the SMP Console.

  2. In the grid below, select as many task instances as possible.

     

    • Tip: Use the CTRL + A key combination to select all available task instances in the grid.

  3. Right-click the selection and choose Delete.

  4. Once task instances are deleted, you can then start the "Clean up Task version Data" task (Settings > All Settings > Maintenance > Server Tasks > Task Service > Clean up Task Version Data) to purge the old unnecessary task versions.