ConnectAll error encountered when running Automation - Un-authenticated Exception in getting the user timezone
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ConnectAll error encountered when running Automation - Un-authenticated Exception in getting the user timezone

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Article ID: 419227

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Updated On:

Products

ConnectAll SaaS ConnectALL ConnectAll On-Prem

Issue/Introduction

When running a ConnectALL automation, the job fails with the error message: "Un-authenticated Exception in getting the user timezone" or a related 401 Unauthorized status code. This prevents the synchronization of artifacts

Cause

The connector's underlying connection was configured using credentials (likely a User ID or password) that had expired, were revoked, or did not have the necessary permissions for the integrated application. The 401 response explicitly indicates a lack of authentication/authorization.

 
 
 
 
 

 

Resolution

To resolve this issue, update the failing connection to use a Service Account or a dedicated API Token that has non-expiring credentials and the required permissions for the integrated application.

Additional Information

 

  • This issue is typically related to permissions or credential expiration, often resolved by moving away from a single user's credentials to a Service Account.

  • The "Unauthenticated Exception in getting the user timezone" text is often a secondary symptom that occurs because the initial authentication check (the 401 error) failed.