vIDM cluster health status is RED due to corrupted file "/etc/init.d/pgService"
search cancel

vIDM cluster health status is RED due to corrupted file "/etc/init.d/pgService"

book

Article ID: 419156

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • On Aria Lifecycle Manager, the vIDM cluster health status is "RED";

  • When trying to remediate the vIDM cluster on Aria Lifecycle Manager, there is LCMVIDM73107 error;

  • When checking vIDM cluster status by commands below, the result looks good:
    • su root -c "echo -e 'password'|/usr/local/bin/pcp_watchdog_info -p 9898 -h localhost -U pgpool"
    • su root -c "echo -e 'password'|/opt/vmware/vpostgres/current/bin/psql -h localhost -p 9999 -U pgpool postgres -c \"show pool_nodes\""
  • When executing command "/etc/init.d/pgService status" on Primary node, there is error like "/etc/sysconfig/pgpool: No such file or directory"

Environment

VMware Identity Manager 3.3.x

Cause

File "/etc/init.d/pgService" on Primary node was damaged.

Resolution

  1. Take snapshot for all vIDM nodes;
  2. Stop pgService on two Standby nodes by command "/etc/init.d/pgService stop"; 

    On Primary node, the command "/etc/init.d/pgService stop" cannot work due to this issue.

  3. On Primary node, run command "cp /etc/init.d/pgService /root/" for backup;
  4. On Primary node, edit file "/etc/init.d/pgService", find the line "source /etc/sysconfig/pgpool" and comment it out;
  5. On Primary node, stop pgService by command "/etc/init.d/pgService stop";
  6. Copy file "/etc/init.d/pgService" from one Standby node to replace the file "/etc/init.d/pgService" on Primary node;
  7. Run command "/etc/init.d/pgService start" on all three vIDM nodes;
  8. Run command "service horizon-workspace restart" on Primary node;