NSX Edge management IP unreachable after redeployment.
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NSX Edge management IP unreachable after redeployment.

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Article ID: 419114

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Redeployed NSX Edge using the API according to the documentation below.
    Redeploy an NSX Edge Node

  • Changed the "default_gateway_addresses" field in the POST API payload.

  • After redeployment, confirmed that communication is not possible from remote subnets.

  • Confirmed that communication is possible from the same subnets.

Environment

VMware NSX

Cause

The cause was an error in the modified "default_gateway_addresses", which resulted in the gateway becoming unreachable.

Resolution

  • When changing parameters during NSX Edge redeployment, ensure that the configuration values are correct.

  • To change the gateway for the management IP address, follow the steps below.

    1. Log in to the NSX Edge CLI as the admin user.

    2. Execute the following command to check the current configuration values of the management interface.
    get interface <mgmt-interface-name>

    3. Execute the following command to change the gateway IP address.
    set interface <mgmt-interface-name> [ip <prefix-ipv46> [gateway <gateway-ip>] | dhcp] plane <plane>

    4. Execute the following command to verify that the settings have been changed.
    get interface <mgmt-interface-name>

Additional Information

For details on the command to change the gateway IP address, refer to the document below.
NSX CLI Guide