Duplicate / Deleted Endpoints Displaying on the Not Enabled Inventory Tab
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Duplicate / Deleted Endpoints Displaying on the Not Enabled Inventory Tab

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Article ID: 419076

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Updated On:

Products

Carbon Black Cloud Workload

Issue/Introduction

  • Devices that are already exist on the Inventory > VM Workloads > "Enabled" Inventory tab, also appear on the "Not Enabled" tab
  • Devices that have been deleted/uninstalled/removed from vCenter appear on the "Not Enabled" tab

Environment

  • Carbon Black Cloud Console

Cause

Under investigation (CRE-22022)

Resolution

  1. For each duplicate click the Take Action > install Sensors button.
    • This should correct the record (if it's a duplicate/no longer exists).
  2. If the above does not work:
    1. Create new Access Level with “collector.vcenter” Permissions
      1. Go to Settings -> API Access -> Access Levels and Click “Add Access Level”
      2. Set the Name and Description and select DELETE check box of “collector.vcenter” and save
    2. Create a new API Key using delete access level
      1. Go to Settings -> API Access -> API Keys and click “Add API Key”
      2. Set the name and select Access Level Type = Custom from dropdown
      3. Select Custom Access Level which is created in step 1 and save.
    3. Copy API ID and API Secret Key from dialog box that appears after save.
  3. Open a Technical Support Case, and provide the API ID and API Secret Key.
  4. Support will send a request to the Workload Appliance to Resync it's inventory (requires a restart of the appliance).