VM is unresponsiv/stuck at the VMware logo boot screen when using an RDM disk
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VM is unresponsiv/stuck at the VMware logo boot screen when using an RDM disk

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Article ID: 419058

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • A VM is using an RDM disk or RDM disks set to physical mode and is unresponsive.
  • When attempting to access the console of the VM, using the vSphere or host client, the task bar does not progress and appears stuck:

  • The console is unresponsive to user/keyboard inputs.
  • Power cycling or cold booting the VM does not resolve the issue.
  • Changes to the RDM mapping have taken place and the original RDM disks are still attached to the VM.
  • In the /var/run/log/vmkernel.log file of the ESXi host, the following entry is observed related to the device backing the RDM disk:
    • YYYY-MM-DDTHH:MM:SS.249Z In(182) vmkernel.log: cpu5:2097283)ScsiDeviceIO: 4606: Cmd(0x45ba83ffa440) 0x2a, CmdSN 0x5ce066b from world 66436140 to dev "naa.<device_id>" failed H:0x1 D:0x0 P:0x0  

Environment

VMware vSphere 8.x

Cause

The RDMs were remapped, meaning that the LUN(s) no longer exist.

As described in KB: Understanding SCSI host-side NMP errors/conditions in ESXi, H:0x1 is returned if the connection is lost to the LUN. This can occur if the LUN is no longer visible to the host from the array side or if the physical connection to the array has been removed.

Resolution

Remove the old RDM disk(s) from the VM, see KB: How to remove a Hard disk or RDM from a powered on virtual machine

After the disk(s) are removed, the VM will become responsive again.

Additional Information

For more information: