Unable to create HCX Site Pair: "Site-Pair already exists between the sites"
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Unable to create HCX Site Pair: "Site-Pair already exists between the sites"

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Article ID: 419048

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Updated On:

Products

VMware HCX

Issue/Introduction

  • You are trying to create the Site Pair, and it's failing with the error: "Site-Pair already exists between the sites"
  • From HCX Standalone UI -> Site Pairs, the site pairing you are trying to add does not exist and is not displayed.
  • The following error is observed in /common/logs/admin/web.log
    <timestamps> UTC [https-jsse-nio-8443-exec-4, Ent: HybridityAdmin, , TxId: TxId: ########-####-####-####-########] ERROR c.v.v.h.api.registration.CloudConfig- Unable to addCloud: Site-Pair already exists between the sites
    com.vmware.vchs.hybridity.api.exception.BadRequestException: Site-Pair already exists between the sites

Environment

VMware HCX

Cause

This issue typically occurs when a previous site pair was not properly removed, leaving residual entries in the HCX Manager database. Because the site pair no longer exists in the UI but the database still contains stale records, the API cannot communicate with the remote site to perform a standard cleanup. This forces the need for manual database cleanup to remove the orphaned entries before a new site pair can be established.

Common scenarios that lead to this condition include:

  • Site pair deleted from only one side of the connection
  • HCX Manager restoration from backup after site pair was removed on the peer site
  • Network connectivity loss during site pair removal
  • Incomplete or interrupted site pair deletion operations

Resolution

If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.

Note: Broadcom Support has access to internal SQL commands that can be used to identify the UUID of a stale site pair entry if it is no longer visible in the HCX UI. This is necessary when the site pair has already been deleted from one side of the connection but residual database entries remain.

Additional Information

If you are contacting Broadcom support about this issue, please provide the following:

  • HCX Manager Connector logs (including the database).
  • HCX Manager Cloud logs (including the database).