Error: "CNF130003 HelmTermination Failed. Reason: Internal Service Error Helm Termination Failed. HelmTermination task timed out"
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Error: "CNF130003 HelmTermination Failed. Reason: Internal Service Error Helm Termination Failed. HelmTermination task timed out"

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Article ID: 418989

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Updated On:

Products

VMware Telco Cloud Automation

Issue/Introduction

  • Found below errors on the TCA-CP UI

    CNF130003    Helm Termination Failed.   Reason: Internal Server Error            Helm termination failed: 0/2 pod(s) satisfied condition 'DELETED': timed out
    CNF130003    Helm Termination Failed.   Reason: Internal Server Error            Helm Termination Failed Release 'cnf-deployment-xxx' not found

Environment

2.3, 3.2, 3.3

Cause

  • Timeout failures can often be attributed to a pod getting stuck during the uninstalling phase, causing the CNF terminate operation to time out. 
  • While the UI reports the task as timing out, the original termination task successfully completed the uninstallation.
  • Attempted retries of the terminate task will fail because the release name in the helm history can no longer be found.

Resolution

Resolved in 3.4

Workaround

  1. Allow Terminate task to fail.
    Note: The timeout takes approximately a hour.
  2. Go to Inventory > Network Function.
  3. Click the Options (three dots) icon for the desired network function, select Reset State, and click OK to confirm.
    Note: There will not be an associated task/event in the UI related to the Reset State command.
  4. Once Terminate task has been set to Completed, click the Options (three dots) icon for the desired network function, and select Delete.
  5. Perform and CNF-specific cleanup to ensure all CNF artifacts have been removed. 
  6. Instantiate the CNF anew.

Additional Information

Any failures to instantiate the CNF following the deletion of the CNF will be directly attributed to CNF-related artifacts still existing. 

If CNF Instantiation failure is encountered run through the following:

  1. Click the Options (three dots) icon for the desired network function and select Rollback and click OK to confirm.
  2. Once complete, click the Options (three dots) icon for the desired network function, and select Delete.
  3. Engage the vendor as needed to fully clean up the CNF before attempting to instantiate the CNF again.