SRM Test Recovery fails with "Timed out waiting for VMware tools after 300 seconds"
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SRM Test Recovery fails with "Timed out waiting for VMware tools after 300 seconds"

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Article ID: 418988

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • The issue is verified by reviewing the vmware-dr.log file on the SRM server. A confirmed failure will show the 300-second watchdog timer expiring with the following specific errors:

2026-05-21T12:47:37.810+05:30 error vmware-dr[695853] [SRM@6876 sub=Recovery ctxID=bd06b1d0 opID=0b3a6712-8e96-4cc6-8f0a-8c2e13c67c77-test:47bd:d5e2:4420] [755c52d7-b121-417d-bf6b-4c4208b4528d.ipCust-protected-vm-17396353] Unable to customize VM vm_name [vm-####]; wait for tools failed: (dr.recovery.fault.ToolsTimedout) {
-->    faultCause = (vmodl.MethodFault) null,
-->    faultMessage = <unset>,
-->    timeout = 300
-->    msg = ""
--> }

  • The virtual machines on the production site has open-vm tools installed and running. This can be verified using the below commands
    rpm -qa | grep open-vm-tools
    systemctl  status vmtoolsd

Environment

  • VMware Site Recovery 9.x
  • VMware Live Recovery 9.x

Cause

  • The Guest Operating System (OS) is in emergency mode at the recovery site. Because the OS fails to fully initialize its kernel or services in time, the VMware Tools daemon (vmtoolsd) never starts. Without this service running, the Guest OS cannot report its "OS Family" and "Heartbeat" to SRM, causing the SRM wait timer to expire.
  • The below vmware-dr.log entry confirms that SRM timed out while waiting for VMware Tools to report the guest operating system information:

2025-11-07T11:44:27.520+05:30 error vmware-dr[02231] [SRM@6876 sub=Recovery ctxID=89c7f8a5 opID=c2b84921-xxxx-xxxx-xxxx-xxxxxxxxxxxx-test:xxxx:xxxx:xxxx:xxxx] [4cf975ed-xxxx-xxxx-xxxx-xxxxxxxxxxxx.ipCust-protected-vm-xxxxxx.waitForTools-vm-xxxxx] Timed out while Waiting for OS family to become known from VM tools; [vim.VirtualMachine:33765f57-xxxx-xxxx-xxxx-xxxxxxxxxxxx:vm-xxxxx]; timeout (secs): 900

  • While manually powering on the virtual machine on the DR site on the isolated test network shows that the virtual machine fails to boot and enters emergency mode

Resolution

To resolve the issue, troubleshooting must focus on the guest operating system boot failure instead of the SRM application.

The guest OS should be checked from the VM console at the recovery site to identify why it is entering emergency mode during startup.