SystemEDGE Cisco UCS - no data in Spectrum
search cancel

SystemEDGE Cisco UCS - no data in Spectrum

book

Article ID: 418982

calendar_today

Updated On:

Products

SystemEDGE Agent Spectrum Network Observability

Issue/Introduction

We installed the SystemEDGE agent on a Windows server at the customer's environment and added the CiscoUCS plugin. The agent is connected to Cisco UCS Manager and appears to be functioning correctly.

However, when I try to run a walktree on the CiscoUCS MIB – 1.3.6.1.4.1.546.16.58.3 – I receive an empty output.

(walktree.exe -p 161 -v 3 -u sysedge -s AuthPriv -A SHA -a xxx-X AES -x xxx -o 1.3.6.1.4.1.546.16.58.3 > walktree.txt)

                               WALK TREE output

-----------------------------

 

Node Addr: localhost

Port: 161

Subtree  : 1.3.6.1.4.1.546.16.58.3

 

LEN      MIB PATH            TYPE  VALUE

---      --------                       ----  -----

When I added the SystemEDGE agent to DX Spectrum, I also do not see any data.

Environment

DX NetOps Spectrum 24.3.10 and SystemEDGE 6.5.0 (upgraded from 6.4.0)

Cause

We currently provide support for UCS system components, such as chassis, fabric interconnects, blades only, We are not parsing the rack-mounts. However, based on the debug SystemEDGE  log output from the customer's environment, it appears that no chassis is present. As a result, SystemEDGE  is unable to proceed with further information exploration.

Resolution

SystemEDGE 6.x is an updated version of 5.9. We have mitigated the vulnerabilities present in 5.9 and have neither removed nor added new features in 6.x

The Rack-Mount Servers were not supported 5.9, hence it is not supported in 6.x.

Additional Information

The Spectrum documentation for Cisco UCS monitoring states and lists the supported UCS components/inventory which can be referred using the link below:

Cisco Unified Computing System

Cisco Unified Computing System
Last Updated October 13, 2025

Cisco Unified Computing System (UCS) comprises a set of specialized devices working together, including the blades of the chassis and server. UCS supports the data center by delivering a dynamic IT infrastructure and by unifying network, computing, and virtualization resources.

DX NetOps Spectrum provides visibility into the following key components of Cisco UCS:

  • UCS Manager
    A web services agent running on a Fabric Interconnect switch. The Cisco UCS manager supports an XML-based API for client interaction.

  • Fabric Interconnect (FI) Switch
    • Typically two per UCS system; Cisco recommends a redundant configuration
    • Runs NX-OS
    • Hosts the UCS manager

  • Chassis
     An agentless, switchless, blade server enclosure, with a maximum configuration of 40 chassis per UCS manager. Each chassis supports 8 half-width or 4 full-width server blades.

  • Blades
     A server platform that serves as a virtualization host.

  • Service Profiles
    Logical views of blade servers. Stored in the FI switch, they contain the blade server personality (identity and network information).

Since rack-mounts are not part of the above list, indicates that the monitoring for it is not supported.

Please open a new case to raise an Enhancement Request (RFE) for supporting rack-mounts by filling up the form in this KB article:

Enhancement request process for Broadcom's AOD Division