Session Logs "Users(Group)" filter doesn't work
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Session Logs "Users(Group)" filter doesn't work

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Article ID: 418947

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

We have tested the following simple filtering via User Groups on Session logs page, it does not work even with existing User Group

We can reproduce the problem with the following steps:
1. Launch PAM Client, login as 'super', go to Sessions >> Logs
2. Make sure you have session logs with User Groups equal to "TAP Administrator"
3. Click the table header down arrow icon -> select Columns and add User Groups column
4. Select "Users(Group)" as the "Column" and set the "Value" as e.g. "TAP Administrator"
5. Click the [Filter] button and the page becomes blank

Environment

PAM 4.2.x, 4.3.x

Cause

This is a known issue

Resolution

Our code attempts to match the User Group filter with the transaction type. For example, if a User Group is created with the name "login" and we apply a filter on that User Group, the system currently returns all messages with the transaction type "login".

At the time of writing this article, Engineering is actively working on this issue under ticket DE652553.

Please raise a Support case and reference this Knowledge Base article so that we can assist you with the appropriate solution.