HCX NE/IX appliance deployment fails
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HCX NE/IX appliance deployment fails

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Article ID: 418907

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Updated On:

Products

VMware HCX

Issue/Introduction

  • While deploying the service mesh or during re-deploying the NE/IX appliance, it fails with the error below on HCX UI.
Deploy and Configuration of Interconnect Appliances Failed. Interconnect Service Workflow
AllocateResourcesForinterconnectAppliance failed. Error: IP address <Ip-Address> assigned to the appliance <HCX-Appliance-Name> for the <Network-Name> network is already being used. Please edit the network profile to remove this IP address.
  • The screenshot of the error is shown below.

 

Environment

HCX

Cause

  • The deployment of service mesh or NE/IX appliance will fail if there is an IP address conflict (Duplicate IP) on the network.

Resolution

  • Ensure the IP address range defined in the Network Profile of HCX does not overlap with an existing IP in the network.
    • Login to the HCX Manager UI https://<NSX-Manager-IP> 
    • Navigate to Interconnect --> Network Profiles 
    • Click on the corresponding Network Profile that is being used for the Service Mesh or NE/IX appliance
    • Verify that the IP range mentioned does not conflict with any existing IPs.
    • Check with the customer's DNS team or use nslookup on the IP to further confirm if the IP range mentioned in the Network Profile is already assigned to any other appliance/system in the network.
    • Edit and Update the Network Profile to ensure only unique IPs are allocated.
    • Try Redeploying/Re-sync the Service Mesh or IX/NE appliances.