API calls to replace NSX certificate fails with "The credentials were incorrect or the account specified has been locked."
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API calls to replace NSX certificate fails with "The credentials were incorrect or the account specified has been locked."

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Article ID: 418867

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Updated On:

Products

VMware NSX

Issue/Introduction

When attempting to run API calls via the Postman program to replace expired NSX certificates they fail with the error:

The credentials were incorrect or the account specified has been locked

Environment

VMware NSX

Cause

The program Postman is unable to authenticate to the NSX Managers due to:

  • Incorrect credentials
  • Missing credentials
  • Account has been locked due to incorrect credentials being used too many times

Resolution

Before running the API calls via Postman, ensure the correct credentials have been entered:

  1. Click on Authorizatio
  2. For Type select Basic Auth
  3. Enter the admin credentials for the NSX UI

If its verified the credentials in use are correct, and the above does not resolve the issue, please open a support case with VMware by Broadcom.