Unable to view registered workflows in GT DataMaker
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Unable to view registered workflows in GT DataMaker

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Article ID: 418835

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

After upgrading TDM from v4.9 to v4.11, we are not able to view registered workflows in GT DataMaker.

How can I see the path?

In which table of  GTREP schema are the Javelin workflows stored?

Environment

GT Data Maker - All supported releases

Javelin - All supported releases

Cause

The "View Workflow"  button uses a Windows Registry entry to locate the Javelin.exe. 


Check the Windows Registry for the following:

[HKEY_CURRENT_USER\SOFTWARE\GRID-TOOLS\GTDatamaker\Javelin]
"Location"="C:\\Program Files\\Grid-Tools\\Javelin\\Javelin.exe"

Note: C:\\Program Files\\Grid-Tools\\Javelin\\Javelin.exe is the default installation path. If Javelin was installed in a different location, in your environment, then you need to point to the installation path for Javelin.exe.

 

Resolution

To correct the Windows registry, try updating the registry by specifying the location where your Javelin is installed.

  1. Create a reg file called javelin.reg containing the following:

    [HKEY_CURRENT_USER\SOFTWARE\GRID-TOOLS\GTDatamaker\Javelin]
    "Location"="C:\\Program Files\\Grid-Tools\\Javelin\\Javelin.exe"

  2. Inserting the content to the correct path (as mentioned above), by importing the javelin.reg file into your Windows Registry.

    Note: You may need to have a Windows system Admin assist you in correcting the Windows Registry,
     
  3. After correcting the location, launch Data Maker, and try viewing your registered flows.