Error : Timeout has occurred while pairing the sites in VMware Cloud Director Availability
search cancel

Error : Timeout has occurred while pairing the sites in VMware Cloud Director Availability

book

Article ID: 418714

calendar_today

Updated On:

Products

VMware Cloud Director Availability - Disaster Recovery 4.x

Issue/Introduction

Unable to pair the sites in VMware Cloud Director Availability (VCDA), the task fails with an error similar to:
Error : "Timeout has occurred"

Attempts to repair the site on both the source and destination have not resolved the issue, and the problem persists

/opt/vmware/h4/replicator/log/replicator.log reveals the following error details:
 
 TunnelRouteStatus{type=CLOUD, address='##.##.##.###', port=8046, error=ApiOptional{value=null}}, TunnelRouteStatus{type=LWDPROXY, address='##.##.###.###', port=44045, error=ApiOptional{value=null}},  error=ApiOptional{value=null}}, TunnelRouteStatus{type=MANAGER, address='##.##.###.###', port=8044, error=ApiOptional{value=null}}, TunnelRouteStatus{type=LWDPROXY, address='##.###.###.##', port=44045, error=ApiOptional{value=null}}, TunnelRouteStatus{type=TUNNEL, address='##.##.###.##', port=8048, error=ApiOptional{value=ApiError{code='ConnectTimeout', msg='HTTP connect timeout.', stacktrace='com.vmware.exception.ConnectTimeout: Connect to 10.###.###.###:8048 failed: Connect timed out'}}

The logs indicate a connection timeout, which may be caused by issues with DNS, routing, or network configuration related to the TUNNEL service.

Environment

VMware Cloud Director Availability 4.x

Cause

A connection timeout error has been observed, which could be caused by issues with DNS or network connectivity

Resolution

Once DNS and network connectivity to the replication manager are restored, please retry the pairing process and it should complete successfully.

Network requirements and prerequisites in the Cloud Director site