"Your host license expires in days. The host will disconnect from vCenter Server when its license expires" alarm appears on the vSphere and Host Client Summary Page
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"Your host license expires in days. The host will disconnect from vCenter Server when its license expires" alarm appears on the vSphere and Host Client Summary Page

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Article ID: 418692

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

"Your host license expires in days. The host will disconnect from vCenter Server when its license expires." alarm triggered in vSphere and ESXi Host Client Summary page

Note: The '5 days' shown in the above screenshot is for illustrative purposes; the actual number of days displayed will vary based on the specific license expiration schedule.

Environment

VMware vCenter Server
VMware vSphere ESXi

Cause

This occurs when the license key assigned to the ESXi host is nearing the end of its validity period.

The vpxa performs periodic checks on license status and triggers an alarm when the expiration date is near.

Resolution

To resolve this alarm and prevent host disconnection, a valid license key must assigned. The below steps guide through retrieving the correct license from the Broadcom portal, adding it to the vCenter inventory, and assigning it to the specific ESXi host.

Check the Available Licenses

  1. Login to Broadcom Support Portal
  2. Navigate to the My Entitlements > Select the SITE ID > Entitlement details > Select the product > Select the license badge icon to move into the licensing page and Select the license key that matches your current ESXi version.
    1. If a license is available: Copy the license key and skip directly to the Assign the License to the Host section
    2. If only an older license version is visible, an upgrade can be performed in the portal by following Upgrade and Downgrade VMware License Keys via the Broadcom support portal. If the upgrade option is greyed out or the correct license is unclear, a Non-Technical Case should be opened with Global Customer Assistance team following "Create a Non Technical case for Support Portal / License / Contract related issues" 

Assign the License to the Host in vSphere Client

  1. Adding a license key in the vSphere Client
    1. In the vSphere Client, navigate to Administration > Licensing > Licenses
    2. Select the Licenses tab >Click on ADD Icon
    3. In the text area of the New License dialog box, enter license keys > Click Next 
    4. In the Edit License names page, add the license name and click Next.
    5. In the Ready to complete page, review the license keys to add and click Finish.
  2. Assign the license key to an ESXi host in the vSphere Client following the steps below: 
    1. In the vSphere Client, go to Inventory (Host and Clusters) and  select the specific Host that requires license assignment  
    2. Click on the Configure tab in the right pane 
    3. On the left-hand sidebar, scroll down to the System section and select Licensing
    4. Click ASSIGN LICENSE.
    5. Review the License details and click OK  
  3. Assign the License key to a standalone ESXi host:
    1. Login to the Host UI using "root" account 
    2. In the left pane of the Host Client, click Manage and then select the Licensing tab
    3. Click Assign license, enter a license key, and click Check license
    4. Click Assign License to save the changes 

Additional Information

For information on the impacts resulting from the expiration of an ESXi host or vCenter Server license, see Impact of vCenter/ESXi license expiration.