Aria Automation selecting wrong Azure landing zone
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Aria Automation selecting wrong Azure landing zone

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Article ID: 418646

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • When testing the deployment from the blueprint, Automation is not choosing the right Availability Zone available for the VM SKU selected
  • In the provisioning diagram the Compute Host placement shows that it did not get placed on the desired zone with a message similar to this:
    Not Selected because: Requested instance type (<Selected Instance Type>) is not supported on the Requested Availability Zone (<Desired Zone Name>) 
  • Querying Azure directly shows that the requested instance is not restricted in the desired zone
  • Aria Automation is properly configured to use Azure Availability Zones

Environment

Aria Automation 8.x

Cause

Flavor mappings or other data may be cached in the service if recent changes have been made in Azure

Resolution

Restart the provisioning-service-app pod to release the cached Flavor mappings (this will restart all provisioning-service-app pods in the cluster):

  1. SSH into one appliance with the root account
  2. Restart the provisioning-service-app pod
      kubectl -n prelude delete pod -l app=provisioning-service-app
         Note: this will restart the pod on nodes in the cluster
  3. Monitor the provisioning-service-app pod(s) to ensure it is running
      kubectl -n prelude get pods | grep provisioning-service-app
  4. Retry the deployment test