VMware Cloud Proxy Not Connecting to Aria Operations
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VMware Cloud Proxy Not Connecting to Aria Operations

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Article ID: 418634

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

When deployed, the VMware Cloud Proxy does not connect to Aria Operations/vROPS. 

  • You see the UI error message: Failed to connect to VMware Aria Operations after 30 tries
  • In vCenter, the console for the Cloud Proxy shows Exceeded max retry count
  • After logging into the console of the Cloud Proxy with root:
    • Running route -n may show an incorrect is missing gateway address
    • Running ifconfig may show an incorrect subnet mask for eth0
  • Within /casa/casa.log on the Aria Operations appliance, the following entries are seen: 

2025-11-04T13:58:03  WARN [#################] [#########] casa.exception.CasaControllerExceptionHandler:### - general runtime exception
org.springframework.web.client.HttpServerErrorException$ServiceUnavailable: 503 Service Unavailable: "<html><body><h1>503 Service Unavailable</h1><EOL>No server is available to handle this request.<EOL></body></html><EOL>"

2025-11-04T13:58:04  INFO [pool-3-thread-2] [N4000003] casa.messaging.RemoteCollectorMessageProcessor:## - Checking cloud proxy connection to vROps cluster

2025-11-04T13:58:04  INFO [pool-3-thread-2] [N4000003] casa.messaging.RemoteCollectorMessageProcessor:## - Cloud proxy instance is not connected yet to vROps cluster: sleep 2000 and retry.

  • When gathering verbose diagnostic logging from the Cloud Proxy direct via command cprc-cli -v -d all the following entries are observed: 

CONNECTION TEST

2025-11-12 15:08:04,042 [144032] - log - INFO - *** Connection analysis begin ...
2025-11-12 15:08:04,042 [144032] - log - INFO - *** Connection analysis for ON-PREM CPRC
2025-11-12 15:08:04,042 [144032] - log - INFO - Analyzing connection with vRops IPs: ['fqdn.example.com']
2025-11-12 15:08:04,042 [144032] - log - INFO - Analyzing connection to vRops IP: vcenter-operations.ugi.com
Connection to vROps: aria_ops_fqdn.example.com without proxy server. CA verification: Disabled
    Conection FAILED: HTTPSConnectionPool(host='fqdn.example.com', port=443): Max retries exceeded with url: /casa/s
ecurity/ping (Caused by NewConnectionError('<urllib3.connection.HTTPSConnection object at #x############>: Failed to establish
 a new connection: [Errno -2] Name or service not known'))
2025-11-12 15:08:04,046 [144032] - log - INFO - *** Connection analysis end ...

 

NETWORK TEST: 

    Domain search list: ['example_domain.com', 'example.com']
2025-11-12 15:08:04,081 [######] - log - INFO - *** Network DNS analysis end
2025-11-12 15:08:04,081 [######] - log - INFO - *** vROps on-prem IP(s) resolution begin ...
    VROPS Host: fqdn.example.com
    FAILED to resolve !
2025-11-12 15:08:04,082 [144032] - log - INFO - *** vROps IP(s) resolution end ...

 

Environment

VMware Aria Operations 8.18.x

Cause

DNS Resolution failure during setup from Cloud Proxy to Aria Operations appliance. 

Resolution

Network settings cannot be changed after deploying the Cloud Proxy. To resolve issue:

  • Redeploy the cloud proxy, ensuring that all network settings are configured correctly (IP, subnet mask, DNS, gateway)
  • Ensure that the configured DNS server(s) for the Cloud Proxy are able to resolve the FQDN of the Aria Operations appliance.