Mismatch in license expiry date post adding the license on VCF 9.x
search cancel

Mismatch in license expiry date post adding the license on VCF 9.x

book

Article ID: 418555

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • There is a mismatch in the license date that you see in "VCFOPS" (VCF Operations) vs what can be seen in Broadcom Portal.
  • The date seen in " VCFOPS" (VCF Operations) is within 180 days and the one in Broadcom Portal is the actual license contract date. 

    Example:

    VCF licenses show version 9 licenses are expiring in 2026, but the contract should be active until 2028 for version 9

  • You may observe license expiration warnings appearing for both newly installed VCF 9 licenses and legacy VCF 5.x licenses.
  • The "Pre-Version 9" license tab displays warnings for legacy capacity (25-character keys) set to expire.
  • The License Management UI confirms a "heartbeat" expiration window of 180 days for Solution License Files.

Environment

VCF 9.x
VCF Operations 9.0.x

Cause

This behavior is by the design of the VCF 9 subscription model and legacy key monitoring:

  1. Heartbeat Mechanism: VCF 9 uses a "Solution License File" that carries a rolling 180-day validity period. This requires periodic usage reporting to automatically extend the window.

  2. Legacy Key Monitoring: VCF Operations continues to report on 25-character keys in the "Pre-Version 9" capacity pool. These keys are independent of the Version 9+ infrastructure but trigger alerts if they are approaching their individual expiration dates.

Resolution

This is expected behavior. 

Before the end of these 180 days the user is obliged to report usage and download new license bundle - this will extend the expiration date with additional 180 days (not beyond the expiration date of the contract).

This holds true for both modes of licenses:

1. Synchronize VCF 9 Heartbeat

For Connected Environments:

  1. Navigate to License Management > Registration

  2. If needed, click  Update Licenses

  3. The system reports usage and automatically downloads the extended license file from the VCF Business Services Console.

    Reference: Update Licenses in Connected Mode

For Disconnected (Air-Gapped) Environments:

  1. Navigate to License Management > Registration.

  2. Click Generate Usage File and download the file.

  3. Upload this file to the Broadcom Support Portal from a machine with internet access.

  4. Download the new License File from the portal.

  5. In VCF Operations, navigate to License Management > Registration > Import License File and upload the new file.

    Reference: Update Licenses in Disconnected Mode for additional steps needed on VCF Business Services console


2. Manage Legacy (Pre-Version 9) Warnings

  • If your old infrastructure is still active: You can safely ignore these warnings. The expiration of legacy keys does not impact the VCF 9.0 environment.

  • If your old infrastructure is decommissioned: Remove the residual keys to clear the alerts.

    1. Navigate to License Management > Licenses.

    2. Click the Pre-Version 9 tab.

    3. Select the old licenses and click Remove.


Additional Information

Licensing in VMware Cloud Foundation 9.0