License Expiry Date Discrepancy in VCF 9.0.x after License addition
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License Expiry Date Discrepancy in VCF 9.0.x after License addition

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Article ID: 418555

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Updated On:

Products

VCF Operations

Issue/Introduction

  • There is a discrepancy between the license date displayed in “VCFOPS” (VCF Operations) and the one seen in the Broadcom Portal.

  • The “Next Usage Report Due” field under License Management -> Licenses may indicate a deadline within 180 days even when the environment is in a connected state, since usage reports are automatically submitted daily.

    Example: On VCF Operations, under License Management -> Licenses, VCF version 9 licenses may appear to expire in 2026, while the actual contract remains valid until 2028 as indicated in the Broadcom Portal.

  • License expiration warnings may also be noticed for legacy VCF 5.x licenses which is managed under 'Pre-Version 9' in License Management.

Environment

VMware  Cloud Foundation 9.0.x

Cause

This behavior is expected as part of the VCF 9 subscription licensing model and legacy license key monitoring.

  • Heartbeat Mechanism: VCF 9 uses a “Solution License File” with a rolling 180-day validity window. Periodic usage reporting is required to continuously renew and extend this validity period automatically.

  • Legacy Key Monitoring: VCF Operations also monitors legacy 25-character license keys under the “Pre-Version 9” capacity pool. These licenses operate independently from the Version 9+ licensing framework, but alerts may still be generated when their individual expiration dates are approaching.

Resolution

Before the 180-day validity period expires, a usage report must be reported and an updated license bundle must be downloaded. This process renews the validity window for an additional 180 days, without exceeding the actual contract expiration date.

This behavior applies to both licensing modes:

1. Synchronize VCF 9 Heartbeat

  • For Connected Environments:

    1. Navigate to License Management > Registration.

    2. Select Update Licenses.

    3. The system will report the usage and automatically download the extended license file from the VCF Business Services Console.

      Refer: Update Licenses in Connected Mode

  • For Disconnected (Air-Gapped) Environments:

    1. Navigate to License Management > Registration.

    2. Click Generate Usage File and download the file.

    3. Upload the file to the Broadcom Support Portal from a machine with internet access.

    4. Download the new License File from the portal.

    5. In VCF Operations, navigate to License Management > Registration > Import License File and upload the new file.

      Refer Update Licenses in Disconnected Mode for additional steps to be followed in VCF Business Services console.


2. Manage Legacy (Pre-Version 9) Warnings

  • If the legacy infrastructure is still in use, these warnings can be safely ignored. The expiration of legacy license keys does not affect the functionality or operation of the VCF 9.0 environment.

  • If the legacy infrastructure has been decommissioned, remove the residual license keys to clear the alerts.

    1. Navigate to License Management > Licenses.

    2. Open the Pre-Version 9 tab.

    3. Select the legacy licenses.

    4. Click Remove to delete the old license entries.

Additional Information

Licensing in VMware Cloud Foundation 9.0