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could not find the main class: com.ca.serviceplus.migration.wizard.migrationwiward. program will exit

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Article ID: 41848

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Symptoms: 

When trying to upgrade SDM version 12.5 or 12.6 to SDM 12.7 executing migrate_to_r12_7.vbs file shows the error:

<Please see attached file for image>

java error.JPG

Environment:  

Upgrading SDM from Version 12.5, 12.6 to SDM 12.7

Cause: 

SDM installation was done in a different drive than C and doesn’t have enable the 8dot3name.

Resolution:

Run the following command on the drive where you plan to install CA SDM:
    <installation drive>:\Users\Administrator>FSUTIL.EXE 8dot3name query <installation drive>:
For example, if you are using the D drive to install CA SDM, then the following command must be used:
D:\Users\Administrator>FSUTIL.EXE 8dot3name query d:

If 8dot3 name creation is disabled on D drive, the following result is displayed:
  The volume state is: 1 (8dot3 name creation is disabled).
  The registry state is: 2 (Per volume setting - the default).

To enable, run the following command:
    <installation drive>:\Users\Administrator>FSUTIL.EXE 8dot3name set <installation drive>: 0
For example,
    D:\Users\Administrator>FSUTIL.EXE 8dot3name set d: 0

Additional Information:

Since 8dotname is a pre requisite to install SDM after enable this option then application will need to be reinstalled.

Environment

Release:
Component: USRD

Attachments

1558721687935000041848_sktwi1f5rjvs16w61.jpeg get_app