vCenter is not visible in Inventory after upgrade to VCF Operations 9.0.x
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vCenter is not visible in Inventory after upgrade to VCF Operations 9.0.x

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Article ID: 418428

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Updated On:

Products

VCF Operations

Issue/Introduction

After upgrading to VCF Operations 9.0.0 (or later), you find that one of your vCenter instances is not visible in the main Inventory views. You can still see data from the vCenter instance in other areas, leading to confusion about its status.

Symptoms and Behavior:

  • In the new Inventory page (Basic View), one vCenter (e.g., vCenter B) is completely missing, while the other vCenter (vCenter A) is visible.

  • The vCenter adapter instance for the missing vCenter (vCenter B) is shown as Healthy and collecting data in the Integrations page and the old Inventory Management page.

  • In the Inventory > Detailed View, you can see both vCenter instances, but the missing vCenter (vCenter B) has a blank value in the 'Type' field.

  • The missing vCenter is actively collecting metrics, confirmed by validating current metric data.

Environment

VCF Operations 9.0.x

Cause

The issue is caused by the 'Cloud Type' field in the vCenter Adapter instance Advanced Settings becoming blank or null during the upgrade from VCF Operations 8.x to 9.0.x.

You can confirm this cause by performing the following check on the missing vCenter adapter instance:

  1. Navigate to the adapter configuration for the vCenter that is missing from the Basic Inventory view.

  2. Review the Advanced Settings.

  3. The 'Cloud Type' field is empty or blank and is not editable.

    • Note: A properly configured vCenter adapter instance that appears correctly will show the 'Cloud Type' field populated with the value: vCenter.

Resolution

This issue is resolved by removing and re-creating the affected vCenter adapter instance to properly populate the Cloud Type field.

Follow these steps in order on the affected vCenter adapter instance (e.g., vCenter B):

  1. Create a snapshot of the VCF Operations appliance before performing any configuration changes.

  2. Stop data collection on the affected vCenter adapter instance.

  3. Add a new vCenter adapter instance using the vCenter's IP address instead of its hostname. Ensure you use the same configuration details (credentials, advanced settings etc.) as the old instance.

  4. Delete the old vCenter adapter instance that had the missing 'Cloud Type' setting.

  5. Edit the newly created vCenter adapter instance (the one using the IP address).

  6. Change the vCenter identifier back to the vCenter's hostname instead of the IP address.

    • You may see the error: Failed to create AI resource. Resource with same key already exists. You can ignore this warning and Save the changes.

  7. Start data collection on the newly configured adapter instance.

  8. Validate functionality by confirming that the vCenter is now visible in the Inventory > Basic View.

  9. Once confirmed, remove the snapshot created in step 1.

 

Workaround:

If you require access to the resources of the affected vCenter instance before applying the resolution:

  • Use the Inventory > Detailed View instead of the Basic View, as the vCenter object is visible there.

  • Use Operations > Configurations > Inventory Management