vSphere High Availability (HA) setup and ESXi update from vSphere Lifecycle Manager fails with error "Software Solution VMware-HBR-Agent cannot be found in depot"
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vSphere High Availability (HA) setup and ESXi update from vSphere Lifecycle Manager fails with error "Software Solution VMware-HBR-Agent cannot be found in depot"

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Article ID: 418412

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Updated On:

Products

VMware vSphere ESXi VMware vCenter Server

Issue/Introduction

  • When attempting to configure vSphere High Availability (HA), the setup fails with the following error:

    vSphere HA agent for this host has an error: vSphere HA agent cannot be installed or configured.
    Software Solution VMware-HBR-Agent cannot be found in depot

  • Performing validation or compliance check of selected image from the updates tab of the cluster, fails with similar errors:

    "Software Solution VMware-HBR-Agent with version 8.0.3-0.0.24299508 cannot be found in depot"

  • The '/var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server.log' on vCenter, following errors are reported:

    error vmware-vum-server[597113] [Originator@6876 sub=com.vmware.vcIntegrity.lifecycle.SetSolutionTask] [SetSolutionTask 365]  Set solution failed. entityId: domain-c#### Problems found while validating the new software spec: {

    -->     "errors": [

    -->         {

    -->             "id": "com.vmware.vcIntegrity.lifecycle.EsxImage.SolutionNotFound",

    -->             "message": {

    -->                 "args": [

    -->                     "VMware-HBR-Agent",

    -->                     "8.0.3-0.0.#####"

    -->                 ],

    -->                 "default_message": "Software Solution VMware-HBR-Agent with version 8.0.3-0.0.##### cannot be found in depot.",

    -->                 "id": "com.vmware.vcIntegrity.lifecycle.EsxImage.SolutionNotFound",

    -->                 "localized": null,

    -->                 "params": null

    -->             },

    -->             "originator": null,

    -->             "resolution": null,

    -->             "retriable": null,

    -->             "time": "<YYYY-MM-DD>T<time>",

    -->             "type": null

    -->         }

    -->     ],

    -->     "info": [],

    -->     "warnings": []


  • Similarly, following errors are reported in /var/log/vmware/vmware-updatemgr/vum-server/imageservice.log:

    [SoftwareSpecMgr 1368] Image validation result: {'info': [], 'warnings': [], 'errors': [{'id': 'com.vmware.vcIntegrity.lifecycle.EsxImage.SolutionNotFound', 'message': {'id': 'com.vmware.vcIntegrity.lifecycle.EsxImage.SolutionNotFound', 'default_message': 'Software Solution VMware-HBR-Agent with version 8.0.3-0.0.##### cannot be found in depot.', 'args': ['VMware-HBR-Agent', '8.0.3-0.0.######']}, 'resolution': None, 'time': '<YYYY-MM-DD>T<time>'}]}

 

Environment

VMware vSphere ESXi 7.x
VMware vSphere ESXi 8.x
VMware vCenter Server 7.x 
VMware vCenter Server 8.x

Cause

The failure was traced to a missing ESXi image component in the depot. Specifically, the VMware-HBR-Agent software solution with the required version could not be found.
This issue occurs when the missing image is set as a desired image. During HA enablement, image validation fails, preventing the HA agent from being installed or configured.

Resolution

To resolve this issue:

  1. Follow the resolution steps outlined in the Broadcom Knowledge Base article: 🔗 KB 380129 – https://knowledge.broadcom.com/external/article?articleNumber=380129 .
  2. For additional background and related scenarios, refer to: 🔗 KB 368749 – https://knowledge.broadcom.com/external/article?articleNumber=368749

    Note: 
    1. Before proceeding to step.3, take a snapshot of vCenter.  For vCenter servers in ELM(Enhanced Linked Mode), please take offline snapshots of  vCenter servers following KB/318333 .
    2. Make a note of any URLs added to Patch Setup as these URLs will be removed after vum database reset.

  3. If the issue persists, reset vum(Update Manager/vSphere Lifecycle Manager) database following https://knowledge.broadcom.com/external/article/412007

By applying the resolution steps, the missing image validation issue can be addressed, allowing patching/update on hosts and vSphere HA to be successfully configured.