NSX Restore button is greyed out on newly deployed manager UI.
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NSX Restore button is greyed out on newly deployed manager UI.

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Article ID: 418302

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Updated On:

Products

VMware NSX

Issue/Introduction

  • A new NSX Manager appliance has been deployed to perform the restore operation.
  • The new manager node is on the same version as the impacted cluster.
  • The appliance has been configured with the same IP address as the original NSX manager node that published the backups.
  • The backup server configuration on the new node is identical to the original cluster's.
  • The UI of the new appliance successfully connects to the backup server and displays the last successful backup file.

  • Despite the backup file being visible, the "Restore" button remains greyed out and cannot be selected.
  • Validating the deployment steps and the configuration of the new NSX manager node, it was identified that the new manager node was of a different appliance type as compared to the impacted cluster.

  • The backup file was generated by a Non-Federated NSX Manager cluster, but the new appliance was deployed with the Global Manager appliance.
  • This is an unsupported restore operation, which resulted in the UI disabling the restore function.

Environment

VMware NSX

Cause

The Restore button is greyed out due to incorrect configurations with the newly deployed NSX manager node.

Resolution

To resolve the issue, ensure that the new NSX manage node deployed for Restore operation is configured with the correct node type (NSX Manager Appliance/Global Manager appliance), IP address/FQDN and so on compared to the impacted cluster.

Additional Information

For detailed information regarding NSX Restore procedure, please refer article: Restore NSX from Backup

And for information related to performing Restore operation in NSX Federation environments, please refer: Backup and Restore in NSX Federation