Unable to add SPE to the SPE console after enabling SSL
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Unable to add SPE to the SPE console after enabling SSL

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Article ID: 418290

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Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS

Issue/Introduction

After enabling SSL for the Symantec Protection Engine (SPE) RestAPI service you attempt to add the SPE to the SPE console, however your receive the following message event though you've selected "Use SSL".

Additionally the CmafUI.log reports entries similar to the following:

[Main UI Thread] ERROR Symantec.Cmaf.Security.AuthManager - Exception is caught while adding server: <SERVER_NAME>. Reason: The remote certificate is invalid according to the validation procedure.
[Main UI Thread] ERROR Symantec.Cmaf.UI.CustomControls.AddServerPane - Failed to add scanner name: <SERVER_NAME>. Reason: The remote certificate is invalid according to the validation procedure.

 

Environment

SPE 9.x

SPE Console 9.x

Cause

The hostname or IP address used to connect to the SPE is not listed as the Common Name (CN) or in the Subject Alternative Name (SAN) of the certificate.

Resolution

Obtain a new certificate that includes the SPE's IP address(es) and hostname(s) in the SAN.