Platform node disk capacity not updated after adding disks in VCF Operations for Networks
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Platform node disk capacity not updated after adding disks in VCF Operations for Networks

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Article ID: 418287

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Updated On:

Products

VCF Operations for Networks

Issue/Introduction

Manual integration of block devices into the /var partition is required when the automatic expansion service fails to detect new disks.

  • vCenter Verification: Hard Disk settings show new disk(s) successfully added to the VM. In the example below you can see 2 1 TB disks added in vCenter.



  • Platform GUI: The 'System Health' or 'Disk Usage' section does not show the expanded capacity.

    In the example below, only 1TB is reported for total disk size despite 2 1 TB disks being added in vCenter (as shown above):



  • Command Line: Running lsblk shows the disks exist as block devices but are not associated with a partition or Logical Volume Manager (LVM) group:

    1. Log into VM in question using SSH with the support user.
    2. Switch to ubuntu user context, with the command:

      ub

    3. Run command to show the disks exist as block devices but are not associated with a partition or Logical Volume Manager (LVM) group:

      lsblk

      As seen in the example output below, "sdb" is not integrated into vg-var:



Environment

VCF Operations for Networks 6.13.0
VCF Operations for Networks 6.14.0
VCF Operations for Networks 6.14.1

Cause

This can occur if either disk is added when the appliances are powered off and, when the appliance is powered on, the cron job is able to detect the new disk but unable to expand the /var partition.

If the disk is added while the appliance is powered on and the VM is immediately rebooted, the cron job will be unable to expand the /var partition.

 

Resolution

To fix this issue with appliance disk, a manual extension of disk to /var partition is needed by identifying the correct disk state.

If you have encountered this issue, ensure you DO NOT perform any manual shutdown or reboot procedure of Platform Node(s).

Open a support case with Broadcom Support to review your Aria Operations for Networks deployment. For more information, see Creating and managing Broadcom support cases. 

While opening case include outputs of below commands:

  1. Login to an SSH session on Platform Node in question as the support user 

  2. Switch to the Ubuntu user using command ub

  3. Run the following commands

    sudo pvs
    sudo lvs
    sudo vgdisplay
    sudo lvdisplay
    sudo lsblk
    sudo fdisk -l


    Note: Outputs of above commands are expected to be longer hence copy/paste the outputs to a Notepad file, save it and upload to this Case for support team to review further.