Error: "No row with the given identifier exists" when trying to view/delete a vApp or VM in VMware Cloud Director
search cancel

Error: "No row with the given identifier exists" when trying to view/delete a vApp or VM in VMware Cloud Director

book

Article ID: 418186

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Trying to view/delete a vApp or a VM from VMware Cloud Director fails with an error similar to:

No row with the given identifier exists: [com.vmware.vcloud.common.model.logicalresource.VdcLogicalResourceModel#########-####-####-####-############]

  • The /opt/vmware/vcloud-director/logs/vcloud-container-debug.log on the VMware Cloud Director Cells show errors of the form:

ERROR    | pool-jetty-########| DefaultExceptionMapper         | Internal server exception | requestId=...

org.hibernate.ObjectNotFoundException: No row with the given identifier exists: [com.vmware.vcloud.common.model.logicalresource.VdcLogicalResourceModel#########-####-####-####-############]

        at org.hibernate.impl.SessionFactoryImpl$2.handleEntityNotFound(SessionFactoryImpl.java:409)

        at org.hibernate.proxy.AbstractLazyInitializer.checkTargetState(AbstractLazyInitializer.java:108)

        at org.hibernate.proxy.AbstractLazyInitializer.initialize(AbstractLazyInitializer.java:97)

        at org.hibernate.proxy.AbstractLazyInitializer.getImplementation(AbstractLazyInitializer.java:140)

        at org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer.invoke(JavassistLazyInitializer.java:190)

        at com.vmware.vcloud.common.model.logicalresource.VdcLogicalResourceModel_$$_jvstdde_1e3.getLrType(VdcLogicalResourceModel_$$_jvstdde_1e3.java)

        at com.vmware.vcloud.valc.config.impl.LogicalResourceConfigFactoryImpl.fromVdcLogicalResourceModel(LogicalResourceConfigFactoryImpl.java:57)

        at com.vmware.vcloud.valc.impl.VmImpl.getStorageClass(VmImpl.java:381)

        at com.vmware.vcloud.api.presentation.service.impl.VAppServiceAdapterImpl.createVmStorageClassAssignments(VAppServiceAdapterImpl.java:1179)

Environment

VMware Cloud Director 10.6.x

Cause

This issue occurs when VMware Cloud Director contains stale database references for a VM that no longer exists in vCenter. It can also occur if the affected vApp contains one or more VMs that are stuck in a "Failed Creation" state.

Resolution

For assistance, contact technical support and note this Knowledge Article ID (418186) in the problem description. For more information, see How to Submit a Support Request.