Error: 'Unable to create disk on any storage entity provided' when attempting to increase Harbor persistent disk
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Article ID: 418113
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Updated On:
Products
VMware Tanzu Kubernetes Grid Integrated Edition
Issue/Introduction
Increasing Harbor tile persistent disk via Opsman fails.
You encounter errors during the Bosh 'post-stop' operation.
The error message reported in Opsman GUI will look like:
Error: Unknown CPI error 'Unknown' with message: 'Unable to create disk on any storage entity provided. Possible errors can be no free space, datastore in maintenance mode or datastores are not accessible by any host' in 'create_disk' CPI method
This might result while attempting to resolve a fully consumed persistent disk on Harbor installed as a tile in Opsman according to this KB
Environment
Harbor tile deployed via Opsman.
Cause
This error is returned from the Infra layer and must be investigated there.
Resolution
Check the datastore in use to ensure it has sufficient storage available, increase if needed.