HCX NE stale vNIC entries after performing the force unextend task
search cancel

HCX NE stale vNIC entries after performing the force unextend task

book

Article ID: 418056

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • An ESXi host was disconnected/down where the NE VM appliance was running.
  • You were trying to unextend a network and performed the force unextend task.
  • The HCX Network extension task completed successfully once this was performed using the force option.
  • Once the ESXi host issue had been resolved, you notice that the vNIC for the unextended network is still present on the HCX NE VM, causing stale entries.

Environment

VMware HCX

Cause

Following the force unextension, the task completed from the HCX perspective; however, the task to remove the vNIC from the NE VM was not passed to the ESXi host since the host was disconnected from vCenter, which led to a stale vNIC interface for the NE VM.

Resolution

Redeploy the HCX HA group/standalone NE to recover and remove the stale entry.
Note: Removing the vNIC from vSphere UI is not supported.