VDT log for vCenter show [FAIL] SSL Connectivity - Investigate error: [<IP_address>:443]:[Errno -2] Name or service not known
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VDT log for vCenter show [FAIL] SSL Connectivity - Investigate error: [<IP_address>:443]:[Errno -2] Name or service not known

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Article ID: 418053

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

          VC Lookup Service Check

            • SSO Site: default-site

                • [PASS]    vCenter.example.com (VC Server or CGW)

                • [FAIL]    <IP_address> (vSphere Replication)
                  [FAIL]    SSL Connectivity
                            Investigate error: [<IP_address>:443]:[Error 113] No route to host

Environment

  • vCenter Server 7.x
  • vCenter Server 8.x

Cause

Leftover service registrations on the lookupservice of the vCenter after decommissioning vSphere replication configuration

Resolution

Please note ensure you have taken proper snapshots of your SSO domain. This means that you must shut down all VCs or PSCs that are in the SSO domain at the same time, then snapshot them, and power them on again.  If you need to revert to one of these snapshots, shut all the nodes down, and revert all nodes to the snapshot

  1. List of the Services  ID registered within the vCenter and using the IP address of the vSphere Replication that is reported in the VDT ,In the below output 3 Service ID are reported

    /usr/lib/vmware-lookupsvc/tools/lstool.py list --url http://localhost:7090/lookupservice/sdk | grep <IP_address> -B 8 | grep "Service ID"

     Service ID: 00f61379-####-####-####-####################_com.vmware.vcHms
     Service ID: h5-dr-####-####-####-####################
     Service ID: d8957e41-####-####-####-####################

  2. The below step would need to be completed for each Service ID that is reported, to run command,  it requires the password for administrator@sso_domain (default SSO domain e.g vsphere.local)

    /usr/lib/vmware-lookupsvc/tools/lstool.py unregister --url https://localhost:7090/lookupservice/sdk --no-check-cert --id  00f61379-####-####-####-####################_com.vmware.vcHms --user administrator@sso_domain --password '<password>'

  3. Once the all the Service ID have been removed restart services on the vCenter 

    service-control --stop --all && service-control --start --all