vCenter Web Client is not accessible with error "This site can't be reached, <vcenter_fqdn> took too long to respond"
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vCenter Web Client is not accessible with error "This site can't be reached, <vcenter_fqdn> took too long to respond"

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Article ID: 417950

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • The vCenter Server Web Client is inaccessible.
  • Browsers display the following timeout error:
    "This site can't be reached. <vcenter_fqdn> took too long to respond."
    or
    "vSphere Client service has stopped working"

  • The Default Gateway is not pingable from the vCenter Server command line.

  • The vCenter Server IP address and the Jump Host IP address reside on different subnets.

  • The environment is identified as air-gapped or highly secured.

  • Nslookup from Jump server to vCenter server do not list the valid output.

Environment

VMware vCenter Server

Cause

1. Since the vCenter Server lacks connectivity to the default gateway, it cannot route traffic outside of its local subnet. Consequently, vCenter will only be accessible from jump hosts connected to the same port group (Layer 2 adjacency), rather than from all jump hosts in the network.

2. The jump server lacks network connectivity to the internal DNS server or does not have the correct DNS server configured on its network adapter, preventing the resolution of the vCenter Server FQDN to its corresponding IP address.

Resolution

Resolution 1: Since the vCenter virtual machine cannot route traffic, you must access it from a Jump Host located on the same Layer 2 network.

  1. Identify a compatible Jump Host:

    • Log in to the ESXi host hosting the vCenter Virtual Machine.

    • Review the list of Virtual Machines and identify any Virtual Machine connected to the same Port Group as the vCenter Server.

  2. Access vCenter:

    • Log in to the identified Jump Host.

    • Attempt to access the vCenter interface from this Virtual Machine.

Resolution 2: 

  1. Log in to the affected Windows jump server with administrative privileges.
  2. Open the network adapter settings and verify the IPv4 configuration.
  3. Update the Primary and Secondary DNS server entries to point to the correct internal DNS servers capable of resolving the vCenter Server domain zone.
  4. Relaunch the web browser and navigate to the vCenter Server FQDN to verify the vSphere Client UI loads successfully.