Disconnects with vCenter seen in NSX logs
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Disconnects with vCenter seen in NSX logs

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Article ID: 417936

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

There is an error that is present in the NSX UI stating "Error: There was an unexpected error occurred while fetching Physical NICs for the host. Please manually enter nic to proceed. (Error code: #####)". However, the thumbprint present in the NSX UI seen in System FabricCompute Manager is correct. 

There may be a log notation within the NSX /var/log/syslog location that report similarly to the below message:

Db(167) Vpxa[2099343]: [Originator@6876 sub=Default] Version negotiation with localhost:443//sdk failed: N7Vmacore4Http13HttpExceptionE(HTTP error response: Service Unavailable)
 In(166) Vpxa[2099404]: [Originator@6876 sub=vmomi.soapStub[1]] SOAP request returned HTTP failure; <SSL(<io_obj p:0x000000c70bf747a0, h:17, <TCP '127.0.0.1 : 22115'>, <TCP '127.0.0.1 : 443'>>), /sdk>, method: selectCapabilities; code: 503(Service Unavailable); fault: (null)
Db(167) Vpxa[2099404]: [Originator@6876 sub=Default] Version negotiation with localhost:443//sdk failed: N7Vmacore4Http13HttpExceptionE(HTTP error response: Service Unavailable)

Environment

VMware NSX 4.x

Cause

Synchronization between the NSX Managers and the vCenter are off, which is preventing the NSX Manager from successfully seeing the correct thumbprint. 

Resolution

If the thumbprint that NSX has for the vCenter is incorrect, please review After the vCenter Server certificate is replaced, the compute manager connection is "Down" in the NSX UI.

Ensure the environment is in a healthy status:

  • NSX Managers all show as UP and the cluster status is reported as Stable by going to System > Appliances 
  • The Compute Manager status is reported as having the registration status as Registered and the connection status reports as Up by going to System > Fabric > Compute Managers
  • Certificates are all reported as valid for both the NSX environment and the vCenter. 

To trigger a resync between the two entities perform the following steps:

  1. Perform a rolling reboot of the NSX Managers, one at a time. Ensuring that the NSX Manager has come completely back up. Please note that if the NSX Manager that is being rebooted was logged into, the UI will stop functioning until all services are back up on that specific Manager. To maintain access to the NSX UI ensure that the user has not logged into the NSX Manager that is being rebooted. 
    • This can be monitored via the NSX UI, System > Appliances > Selecting View Details for the NSX Manager being rebooted. Once the cluster status returns as Stable and all the items below are showing as UP then proceed with the next NSX Manager. 
  2. Once all of the NSX Managers have been successfully rebooted, and the cluster is reporting as stable with all the above items showing as UP, ensure that the Compute Manager reports a stable connection and there is no longer the error/alarm regarding an incorrect thumbprint.

If the above process does not resolve the issue and the alarm is still present, please open a case with VMware by Broadcom Support  and reference this KB. Please ensure to upload all NSX Manager logs, vCenter logs, as well as the ESXi host that houses the vCenter VM. For assistance with this process, please refer to the documents below: