NTP service is not running within the TCA appliances
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NTP service is not running within the TCA appliances

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Article ID: 417848

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Updated On:

Products

VMware Telco Cloud Automation VMware Telco Cloud Platform

Issue/Introduction

NTP service is not running on the TCA appliances even though NTP is set within the Appliance Management portal (9443).

Environment

TCA: 3.0.x, 3.1.x, 3.2.x, 3.3.0.1

TCP: 3.1, 4.0, 4.0.1, 5.0, 5.0.2

Cause

  • By default the NTP Service is disabled
  • The NTP service is set to running but not permanently enabled when NTP is configured within the Appliance Management portal
  • Upon reboot, the service is not started (as it is disabled).

Resolution

  • Resolved in TCA 3.3.0.1

Workaround :

Repeat the steps below for every TCA appliance (Manager and Control-Plane) to enable the NTP Service on boot.

  1. SSH via admin to the TCA appliance
  2. Switch to root user
  3. Edit the file /opt/vmware/scripts/ntp.sh
  4. Add the following line before "systemctl restart ntpd"
    systemctl enable ntpd 2> /dev/null
    systemctl disable systemd-timesyncd 2> /dev/null
    systemctl mask systemd-timesyncd 2> /dev/null
  5. Save the file
  6. Perform any of the following to restart the NTP service:
    1. Login to TCA Appliance Management Port and edit and save the NTP settings
      OR
    2. Run the following commands manually on the SSH shell:
      systemctl disable systemd-timesyncd
      systemctl mask systemd-timesyncd
      systemctl enable ntpd
      systemctl restart ntpd