NTP service is not running within the TCA appliances
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Article ID: 417848
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Updated On:
Products
VMware Telco Cloud Automation
Issue/Introduction
NTP service is not running on the TCA appliances even though NTP is set within the Appliance Management portal (9443).
Environment
3.0
3.1.x
3.2.x
3.3.x
3.4
Cause
The NTP service is set to running when you set the NTP server in the Appliance Management portal. But by default the service is disabled.
Thus, upon reboot, the service is not started (as it is disabled).
Resolution
Workaround - Enable NTP Server:
Repeat the steps below for every TCA appliance (Manager and Control-Plane):
SSH via admin to the TCA appliance
Switch to root user
Edit the file /opt/vmware/scripts/ntp.sh
Add the following line before systemctl restart ntpd systemctl enable ntpd 2> /dev/null systemctl disable systemd-timesyncd 2> /dev/null systemctl mask systemd-timesyncd 2> /dev/null
Save the file
Perform any of the following to restart the NTP service:
Login to TCA Appliance Management Port and edit and save the NTP settings OR
Run the following commands manually on the SSH shell: systemctl disable systemd-timesyncd systemctl mask systemd-timesyncd systemctl enable ntpd systemctl restart ntpd