Issue:
TIM is running with repeated errors in its TIM log. Because of this, we are not able to properly monitor the applications.
In TIM log, we see a lot of errors like:
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**ERROR: hub: hubmanager: cannot link "/<TIM_HOME>/apmpacket/data/pcap/clients/tim/1461067800_1000.pcap" to "/<TIM_HOME>/apmpacket/data/pcap/clients/tim/w22/1461067800_1000.pcap": No such file or directory
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All TIM configurations are set to default including balancer.cnf. Its network interfaces are configured correctly and there is traffic. TIM status showing packets captured as well. No dropped packets.
Environment:
Linux. APM 10.1.
Cause:
This is due to apmpacket is running out of buffer space to handle the incoming traffic. It is necessary to configure apmpacket to use memory-based file system to save buffer space at run-time.
Resolution/Workaround:
You need to mount BOTH apmpacket's pcap and tim logs directories to tmpfs, as following:
1. Commands to run in order for pcap directory:
a. service tim stop
b. service apmpacket stop
c. echo "tmpfs /<TIM_HOME>/apmpacket/data/pcap tmpfs defaults,noatime,mode=0744 0 0" >> /etc/fstab
d. mount /<TIM_HOME>/apmpacket/data/pcap
e. df -k (to verify)
f. service apmpacket start
g. service tim start
2. Commands to run in order for TIM logs directory:
a. cd <TIM_HOME>
b. service tim stop
c. mv logs logs.static
d. mkdir logs
e. chown apache logs
f. echo "tmpfs /<TIM_HOME>/tim/logs tmpfs defaults,noatime,size=1200M,mode=0755,uid=apache 0 0" >> /etc/fstab
g. mount /<TIM_HOME>/tim/logs
h. cp -aR logs.static/* logs/
i. df -k (to verify)
j. service tim start
Additional Information: