Error: Failed to execute GET_CURRENT_IDP task when setting up Identity Broker
search cancel

Error: Failed to execute GET_CURRENT_IDP task when setting up Identity Broker

book

Article ID: 417760

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

When you attempt to deploy or set up the Identity Broker in VCF Operations, the user interface (UI) immediately returns a failure.

The deployment or setup process is interrupted, and you observe the following exact error message:

Failed to execute GET_CURRENT_IDP task

This failure occurs immediately upon attempting to configure the Identity Broker, preventing its successful deployment.

 

Environment

VCF Operations 9.0

VCF Operations 9.0.1

Cause

The vCenter GUID (instanceUuid) is currently set in uppercase within the vCenter Server's configuration file (/etc/vmware-vpx/instance.cfg).

When VCF Operations attempts to perform Identity and Access Management (IAM) flows, the operation fails because the system is unable to match the uppercase vCenter GUID to the adapter resource ID, preventing the "Configure SSO" button from being enabled.

You can identify this cause by observing the following details:

  1. vCenter Configuration: The instanceUuid in the /etc/vmware-vpx/instance.cfg file shows the GUID in uppercase.

  2. Log Error: The vcops-bridge.log shows the resource ID in lowercase cannot be found:

2025-10-01T18:56:32.026Z ERROR vcfops-bridge 5951 [ops@4413 threadId="354" threadName="ServerConnection on port 10000 Thread 1"] [com.vmware.vcops.bridge.server.vidb.adapter.AdapterTaskExecutor.executeTask] - Failed to execute VIM Adapter task
java.lang.RuntimeException: Adapter resource not found for resource id 431a2764-7a22-450e-9ef5-220b0aae70bd

Resolution

A fix is tentatively planned for VCF Operations 9.0.2. Versions and timing are subject to change.