NSX restore button greyed out and not actionable.
search cancel

NSX restore button greyed out and not actionable.

book

Article ID: 417758

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • After configuring the backup server (SFTP) to the correct location and selecting a backup file the GUI option to restore is not clickable for your selected backup and appears greyed out. 
  • Hovering over the button presents a popup stating "Restore operation is allowed only on a newly deployed appliance and if the IP/FQDN of the backup matches the IP/FQDN of the NSX appliance."

 

Environment

  • VMware NSX
  • VMware NSX-T Data Center

Cause

This restore option only becomes available once a restore has been selected that is valid for the currently deployed restore appliance.  This involves a number of checks that must be valid. These values can be mostly observed in the GUI on the restore Backup History. 

  1. The new manager must match the previous managers version exactly.
  2. The new manager must match either the FQDN or the IP of the previous manager, if the previous manager had "publish FQDN" set then the new appliance can be deployed with a different IP as long as the DNS is changed to resolve the new appliance to the relevant FQDN.
  3. If the backup manager had publish FQDN enabled, the new manager must also have this value set.
  4. If the backup manager had dual stack IPv4 and IPv6 configured, the new appliance must also have both IPv4 and IPv6 set.

 

Resolution

Validate the backup file you are using by checking two data points. The GUI will show you the restore files including their FQDN or IP. The other thing to validate is the backup location will generate a folder with the following format in the naming.

<NSX Version including build number><IP stack in use (IPv4,IPv6 or Dual)><Old appliance ID><FQDN or IP>

eg.

Folder Name - 4.2.2.1.0.24765087-Dual-fa961d42-XXXX-XXXX-XXXX-XXXXe8ddb89a-nsx-mngr-01.example
Environment
- 4.2.2.1 version, dual stack, with FQDN publish set.

Folder Name - 4.2.2.1.0.24765087-IPv4-0cac1d42-XXXX-XXXX-XXXX-XXXX8c4be86e-192.168.120.1
Environment -
4.2.2.1 version, IPv4 only, no FQDN publish set.

Folder Name - 4.2.2.1.0.24765087-IPv4-a8021d42-XXXX-XXXX-XXXX-XXXX3846999a-nsx-mngr-01.example
Environment - 4.2.2.1 version, IPv4 only, FQDN publish set.


Then ensure the restore appliance matches each of the values required by doing the relevant actions of the below.

  1. Version - If the restore appliance does not match, a new appliance of the exact version must be deployed.
  2. FQDN or IP of appliance does not match
    1. FQDN - Redeploy the appliance ensuring the hostname/FQDN of the appliance matches.
    2. IP - Redeploy the appliance ensuring the IP of the appliance matches.
  3. FQDN enabled on backup - Follow steps listed in Publish FQDN of the NSX Managers
  4. IP stack (IPv4,IPv6 or Dual) does not match - Configure the appliance interfaces using CLI guide - Set interface or redeploy a new appliance with the correct stacks in use. 

Additional Information

More details on backup and restore procedure can be found in the admin guide Backing Up and Restoring NSX Manager or Global Manager.