VM Remote Console connection through Aria Automation is not working, even once vSphere certificates have been imported into Aria Automation
search cancel

VM Remote Console connection through Aria Automation is not working, even once vSphere certificates have been imported into Aria Automation

book

Article ID: 417740

calendar_today

Updated On:

Products

VCF Automation

Issue/Introduction

  • On opening console connection, the loading ring spins for a while until the common failure message appears as a banner on the page:
    • Cannot establish a remote console connection. Verify that the machine is powered on. If the server has a self-signed certificate, you might need to accept the certificate, then close and retry the connection
    • The blue text links to the Aria Automation base URL
  • Browser dev tools & log messages indicate that the connection was established successfully
  • WebMKS tickets are used for the connection. This is the only remote console connection method allowed with vSphere 8.x
  • The certificates are valid and the resolution from KB 374614 has already been performed.
  • The key log entry is this timeout in provisioning-service-app.log at the time when the banner error above is shown:
    • [vRA host: automation.example.com communicating with vCenter Host: wss://esx-host.example.com:443/ticket/#########]: Exception [connection timed out after 30000 ms: esx-host.example.com/##.##.##.##:443] received while processing vCenter communication.

Environment

  • VMware Aria Automation 8.x
  • VMware vSphere 8.x / 7.x

Cause

Port 443 is not open between all ESX hosts and all Aria Automation nodes. Since the remote console session is sent over TCP 443 and proxied by the Automation nodes, this is required.

Resolution

Ensure that traffic on port 443 is open between all Aria Automation nodes and all ESX hosts which are hosting VMs where the remote console is used.