Unable to connect to vCenter error when creating a replication in VMware Cloud Director Availability
search cancel

Unable to connect to vCenter error when creating a replication in VMware Cloud Director Availability

book

Article ID: 417736

calendar_today

Updated On:

Products

VMware Cloud Director VMware Live Recovery

Issue/Introduction

  • When creating a new replication in VMware Cloud Director Availability, the configure task fails with the error below:

    Unable to connect to vCenter '########-####-####-####-############'

  • There is more than one vCenter connected to the associated VMware Cloud Director environment.
  • The vCenters in use by VMware Cloud Director are not on the same SSO domain.
  • In the destination cloud log on the replication manager appliance (/opt/vmware/h4/cloud/log/cloud.log), an error similar to the following is encountered:

    2025-10-28 16:47:03.298 ERROR - [UI-########-####-####-####-############-####-##] [task-poller-3] com.vmware.h4.jobengine.JobExecution     : Task ########-####-####-####-############ (WorkflowInfo{type='start', resourceType='vmReplication', resourceId='C4-########-####-####-####-############', isPrivate=false, resourceName='null'}) has failed

    com.vmware.h4.replicator.api.exceptions.FailedToAcquireVcConnection: Unable to connect to vCenter '########-####-####-####-############'.
    ...

  • In the manager log on the replication manager appliance (/opt/vmware/h4/manager/log/manager.log), the error can also be seen, as in the example below:

    2025-10-28 16:47:03.290 ERROR - [UI-########-####-####-####-############-####-##-##] [task-poller-3] com.vmware.h4.jobengine.JobExecution     : Task ########-####-####-####-############ (WorkflowInfo{type='start', resourceType='replication', resourceId='H4-########-####-####-####-############', isPrivate=false, resourceName='null'}) has failed

    com.vmware.h4.replicator.api.exceptions.FailedToAcquireVcConnection: Unable to connect to vCenter '########-####-####-####-############'.
    ...

  • On the replicator appliance, an associated error can be found in the replicator log (/opt/vmware/h4/replicator/log/replicator.log), similar to the following:

    2025-10-28 16:47:03.201 DEBUG - [UI-########-####-####-####-############-####-##-##-##-##] [job-43] com.vmware.h4.replicator.vc.VcConnector  : Unable to connect to VC ########-####-####-####-############

    com.vmware.vlsi.client.exception.VlsiClientException: VC not found: ########-####-####-####-############
    ...

Environment

VMware Cloud Director Availability 4.7.3

Cause

A cloud VMware Cloud Director Availability (VCDA) deployment an only be configured to connect to a single vCenter SSO domain. If there are multiple vCenters in use by the VMware Cloud Director (VCD) environment, VCDA will attempt to connect to all attached vCenters using the configured SSO credentials by default. If they are invalid for one or more of the connected vCenters, these connections will fail and attempts to create or manage resources associated with the vCenter will be unsuccessful.

Resolution

In order for VCDA to deploy replications to multiple vCenters, ensure that all items are on the same SSO domain and that the SSO credentials provided have sufficient permissions on each platform.

If placing the vCenters in the same SSO domain is not feasible, deploy a separate VCDA environment for each SSO domain.

Additional Information

In order to reduce the number of errors due to invalid connections to vCenters that are not in the configured SSO domain, vCDA can be configured to only use the appropriate provider virtual data centers (VDCs). For more information regarding the management of accessible provider VDCs, please refer to the following document:

Control the accessible provider virtual data centers