KD not found by keyword
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KD not found by keyword

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Article ID: 41773

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Updated On:

Products

CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Keyword search not working from time to time, search by ID works fine all the time:

  • no error message in the stdlog;
  • pdm_k_reindex done, no error.

Environment

CA Service Desk Manager 17.x

Cause

Inconsistency of 0.ebr or dic.ebr.

Resolution

  1. Stop services
  2. Locate and cut the 0.ebr and dic.ebr files from the $NX_ROOT\site\ebr directory and save them to a folder somewhere as a backup
  3. Use notepad to create blank files 0.ebr and dic.ebr under ebr folder
  4. Do the same to ebr_ADM folder if it exists.
  5. Start services
  6. Run pdm_k_reindex