pgService start/status/stop errors with: /etc/sysconfig/pgpool: No such file or directory
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pgService start/status/stop errors with: /etc/sysconfig/pgpool: No such file or directory

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Article ID: 417719

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • PgService and vPostgres are running only in the primary vIDM nodes. but not running on replica node.
  • However, in one of the nodes the pgService status/start/stop commands gives error with /etc/sysconfig/pgpool: No such file or directory 
  • while remediate we saw an error "LCMVIDM74065"
  • The command su root -c "echo -e 'password'|/opt/vmware/vpostgres/current/bin/psql -h localhost -p 9999 -U pgpool postgres -c \"show pool_nodes\"" will indicate that the status of the node is DOWN.

Environment

VMware Identity Manager 3.3.x

Cause

The /etc/init.d/pgService file is corrupted.

 

Resolution

  1. Take snapshot for all vIDM nodes.
  2. Stop the pgPool service starting with the nodes first and primary last:  
    /etc/init.d/pgService stop
  3. Check if The /db/data directory is empty or has just a recovery.conf and serverlog files. follow KB: Node in VMware Identity Manager will not start Postgres.

  4. cd to /etc/init.d/directory on the replica nodes to check pgService file (compare this file with primary node).  Do not remove/edit any files on the primary node.
    cat pgService
  5. Take backup of pgService file.
    cp -p  pgService pgService.backup
  6. Edit pgService (vi pgService) file on replica node and copy the pgService file content from primary node to replica node.
  7. Start up pgpool starting with master and then the replica nodes: 
    /etc/init.d/pgService start

     

  8. run service horizon-workspace restart  start with primary node
  9. run inventory synch and remediate from LCM and verify that the vIDM is healthy and green