PgService and vPostgres are running only in the primary vIDM nodes. but not running on replica node.
However, in one of the nodes the pgService status/start/stop commands gives error with /etc/sysconfig/pgpool: No such file or directory
while remediate we saw an error "LCMVIDM74065"
The command su root -c "echo -e 'password'|/opt/vmware/vpostgres/current/bin/psql -h localhost -p 9999 -U pgpool postgres -c \"show pool_nodes\"" will indicate that the status of the node is DOWN.
Environment
VMware Identity Manager 3.3.x
Cause
The /etc/init.d/pgService file is corrupted.
Resolution
Take snapshot for all vIDM nodes.
Stop the pgPool service starting with the nodes first and primary last:
cd to /etc/init.d/directory on the replica nodes to check pgService file (compare this file with primary node). Do not remove/edit any files on the primary node.
cat pgService
Take backup of pgService file.
cp -p pgService pgService.backup
Edit pgService (vi pgService) file on replica node and copy the pgService file content from primary node to replica node.
Start up pgpool starting with master and then the replica nodes:
/etc/init.d/pgService start
run service horizon-workspace restart start with primary node
run inventory synch and remediate from LCM and verify that the vIDM is healthy and green