After upgrading ESXi, cannot assign ESXi license from vSphere Client since an expected license is not listed on assignment UI
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After upgrading ESXi, cannot assign ESXi license from vSphere Client since an expected license is not listed on assignment UI

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Article ID: 417652

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Cannot assign ESXi license from vSphere Client since an expected license is not listed on assignment UI.

According to ldif file generated by How to export VMDir information from vCenter Server Appliance, the product version of ESXi is recognized as the version before upgrade.

vmwLicSvcAssetName: <ESXi Name>
vmwLicSvcAssetProductVersion: 7.0    ###<- Even after upgraded to 8.0, ldif shows its version as 7.0

 

Environment

VMware vCenter Server

Cause

It could happen when vCenter Server failed to sync version information to license service.

You might found vpxd.log entries that show an initial spec sync of upgraded ESXi was failed due to license client problem.

YYYY-MM-DDThh:mm:ss.###Z info vpxd[06259] [Originator@6876 sub=vpxLro opID=HB-SpecSync-host-###@0-220e404b] [VpxLRO] -- BEGIN lro-51 --  -- SpecSyncLRO.Synchronize -- 
:::
YYYY-MM-DDThh:mm:ss.###Z error vpxd[06259] [Originator@6876 sub=licenseClientFaultTolerance opID=HB-SpecSync-host-###@0-220e404b] UpdateHostLicenseSpec threw N7Vmacore9ExceptionE(License client start has failed.)
--> [context]zKq7AVECAQAAACqAeAETdnB4ZAAAQxxTbGlidm1hY29yZS5zbwAACBhCACk/QwDIm0qBptsuAnZweGQAgTzcLgKBv/8vAoHovDEBgcnBMQGBGMMxAYGy0IACgf3ggAKB8fN/AoHgyoACAATsNwAXRTgAxQ9RArCOAGxpYnB0aHJlYWQuc28uMAAD3/oPbGliYy5zby42AA==[/context]
YYYY-MM-DDThh:mm:ss.###Z info vpxd[06259] [Originator@6876 sub=vpxLro opID=HB-SpecSync-host-###@0-220e404b] [VpxLRO] -- FINISH lro-51

Resolution

Try reconnecting ESXi host from vSphere Client first, so that the product version might sync properly to license service.

If reconnecting ESXi wouldn't work, raise a support case.