Enterprise Activation Key Status
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Enterprise Activation Key Status

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Article ID: 417619

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Updated On:

Products

VMware HCX

Issue/Introduction

  • When requesting key status from hyperscaler key server , all SystemID's show as "deactivated" from API call issued from hyperscaler key server. 
    {
    
    "status": "DEACTIVATED",
    "systemType": "hcx-enterprise",
    "activationKey": "########",
    "systemId": "<HCX-SystemID>",
    "systemName": "<HCX-SystemName>"
    },
    {
    "status": "DEACTIVATED",
    "systemType": "hcx-enterprise",
    "activationKey": "########",
    "systemId": "HCX-SystemID>",
    "systemName": "<HCX-SystemName>"
    },
    {
    "status": "DEACTIVATED",
    "systemType": "hcx-enterprise",
    "activationKey": "########",
    "systemId": "HCX-SystemID>",
    "systemName": "<HCX-SystemName>"
    },
    {
    "status": "DEACTIVATED",
    "systemType": "hcx-cloud",
    "activationKey": "########",
    "systemId": "<HCX-SystemID>",
    "systemName": "<HCX-SystemName>"
    }]

 

 

 

Environment

VMware HCX in Hyperscaler environments.

Cause

  • HCX Managers will switch to a "deactivated" status if there is no connection to CnC server for 7-14 days. 
  • HCX Managers which are in "deactivated" state typically recover once connectivity is restored and the "link last communicated" entry is updated. 
  • Deactivation mainly occurs if a subscription is no longer valid or activation keys have expired.

Resolution

  • If a particular system restores this communication and "link last communicated" is current , yet still see's the system as "deactivated" - Please open an SR with Broadcom support with System-ID and key so we can work to restore the activation.
    • The 4.10.x HCX Manager must have stable connectivity to CnC server.
    • Post restore of connectivity, the HCX Administrator must upgrade to a non EOS build of HCX. 

Additional Information

  • This API call mentioned in the "Introduction" section of this article is internal to Hyperscaler providers. 
  • If you suspect your enviornment matches this condition, please open an SR with your respective Hyperscaler provider.